1 februari 2009

BankID

Äntligen finns det officiellt stöd för BankID/e-legitimation på Linux/Ubuntu. Tyvärr stödjer de bara 32-bitars Linux, inte 64-bitars. Detta trotts att upp till 25% av Linuxanvändarna idag kör 64-bitars varianten. En stor anledning att många tidigare låtit bli är att stödet för Flash och Java i webläsaren varit dåligt, men det är åtgärdat sedan i höstas.

Lösningen för mig blev att installera en virtuell maskin med 32-bitars Ubuntu på och ha mitt bankid där tills de tagit sitt förnuft till fånga helt. Men visst är något Linux-stöd bättre än inget. Det återstår och se om jag i år kommer att deklarera elektroniskt för första gången.

En sak jag inte förstår med BankId/e-legitimation är varför de bygger på en sluten lösning istället för öppna standarder. I dagsläget är man tvungen att lita på att en specifik leverantör utvecklar stöd för ens favoritläsare.

1 kommentar:

Kraxpelax sa...

Andreas Lundstedt "hyllades för att ha kommit ut som HIV-positiv". Vad är det för en merit!?!? Så djävla äckligt.

- Peter Ingestad, Solna